Coleman evcon blower continues to run with switch in cool

Questions about repairs and parts for Coleman furnaces, air conditioners and heat pumps for manufactured homes. Click here for Coleman parts.

Moderators: Greg, Mark

Locked
mldman75
Posts: 2
Joined: Wed Mar 21, 2012 1:10 pm

Wed Mar 21, 2012 1:40 pm

I have a 2-wire A/C control box # 7900A6021 running a coleman evcon presidential furnace system. When I switched to cool this spring the blower automatically kicked on and so did the outside A/C unit. As long as the Heat/cool switch is toggled to cool the unit runs all the time. The outside a/c contacts are engaged the entire time as well. The outside contacts will not disengage until I switch the Heat/cool switch back to heat and then the system shuts off and contacts on A/C disengage and all appears fine. Everything works just fine with the thermostat on heat. IE: the unit comes on and off like normal blows heat until set temp is obtained. Cold air blows just fine when heat/cool switch is selected to cool it just doesn't matter what the thermostat is set to the system just runs endlessly (woke up to a blissful 62 deg home first night it started )...I've completely disconnected the t-stat to see if that was it...the unit continued to run. I've gently given the relays and contacts,inside the control box, some extra persuasion, (rapped them with hammer a couple times,JK), to release if they were stuck...no luck there. Any Ideas or sugestions. Please and thank you in advance.

Regards,


DaleM
Posts: 385
Joined: Wed Apr 07, 2010 10:07 am

Wed Mar 21, 2012 10:28 pm

What type of thermostat is on the system? Is it a heat/cool thermostat or a heat only thermostat? The 2 wire sytem requires you to use a HEAY ONLY thermostat. The relays in the box are set up to recognize closed contacts on the ts-tat when in heat mode and open contacts on the t-stat when in cool mode. If someone put a heat/cool t-stat on the unit leave the heat/cool switch on the thermostat in the HEAT position and change between heat and cool on the realy box switches.

mldman75
Posts: 2
Joined: Wed Mar 21, 2012 1:10 pm

Thu Mar 22, 2012 11:19 am

Thanks that was it. I just bought this newly remodeled mobile home and it appears they replaced the t-stat. It does have the cool/heat switch. Would it be wise to order a new one or just operate it in the heat mode all the time? Also, as I was trying to figure out why the A/C was running all the time, I noticed a humming noise comming from the control box area. Is it a transformer and should I replace it? Thanks DaleM on the t-stat.

DaleM
Posts: 385
Joined: Wed Apr 07, 2010 10:07 am

Thu Mar 22, 2012 10:57 pm

Transformers hum, nothing to worry about. No need to change the thermostat as long as you understand the operation of it.

Locked