Page 1 of 1

Evcon 7956C856 Won't Turn On

Posted: Sat Sep 07, 2013 3:04 pm
by the_trots

I have visited this forum before and always recieved great help.

My home has a Coleman Evcon Presidential furnace

Model 7956C856

56000 BTU Input

46000 BTU Output

S/N 069166732

This furnace won't turn on. The pilot light was out so I relit it, and it has stayed lit. No matter where the thermostat is set the furnace does nothing. I can hear a hum, I assume this is the transformer. I have turned the furnace off and on numerous times, at the furnace, and at the breaker.

Any ideas?

Thank you.

Re: Evcon 7956C856 Won't Turn On

Posted: Sun Sep 08, 2013 8:11 am
by Greg
If it has a thermocoupler I would check that first. They have been known to out to lunch for no reason. They are relatively cheap and good to have on hand just in case.


Re: Evcon 7956C856 Won't Turn On

Posted: Thu Oct 03, 2013 3:41 pm
by the_trots
Ok Greg,

I will try that. I have been avoiding that because it looks like I have to remove the gas valve to get inside the furnace in any way.

An update I have is that if I short the Red and White wires at the thermostat (tape them together) the furnace runs and heats fine as long as they are shorted together. With a thermostat installed (I have tried 2, an old mercury one and a new Honeywell digital) the furnace will never come on.

Re: Evcon 7956C856 Won't Turn On

Posted: Thu Oct 03, 2013 8:44 pm
by DaleM
If you are twisting red and white together you have already solved your problem. It is the thermostat. Does the new Honeywell have a time delay in it? If so the unit will not come on for a few minutes after the tstat calls for heat. The old tstat may be bad as well as the one on the wall in the first place.