coleman evcon DGATO70800 ac not cooling

Questions about repairs and parts for Coleman furnaces, air conditioners and heat pumps for manufactured homes. Click here for Coleman parts.

Moderators: ponch37300, Mark, flcruising, Greg

coleman evcon DGATO70800 ac not cooling

Postby lictulip » Mon May 09, 2011 12:03 am

HI,

Please help me. My ac is not cooling, last year it worked fined after we put in freon
and charged it because we moved the mobile home. Now that i turn the
thermostat from heat to cool,the unit turns on but after 10-15 min a light
buzz noise comes out and the air comes out at normal temp, the compressor
unit outside turns on, I checked the lines to see if there was a freon leak
but lines seemed fine, not frozen . The A-coil is clean, the red light in
the control panel for the deluxe blend air is flashing( but I thought that only affects the furnace) and when the AC is on the green light stays on. What could be the problem?
lictulip
 
Posts: 1
Joined: Sun May 08, 2011 11:34 pm

Re: coleman evcon DGATO70800 ac not cooling

Postby Bill » Tue May 10, 2011 7:07 pm

Hi,
First thing is that the only way to check to see if you have enough refrigerant is with a gauge set. That will show if you have any refrigerant in your system. It is possible that you have just enough in the system to make it cool for only a couple of minutes then nothing will happen. Since it sounds like everything else is working that is where I would start first.

Thanks,
Bill
Please remember to check and change your filters.
Bill
Moderator
 
Posts: 100
Joined: Mon Mar 07, 2011 9:32 pm


Return to Coleman Service & Repair

Who is online

Users browsing this forum: Google [Bot] and 1 guest