Evcon condenser fan not running, possible capacitor

Questions about repairs and parts for Coleman furnaces, air conditioners and heat pumps for manufactured homes. Click here for Coleman parts.

Moderators: ponch37300, Mark, flcruising, Greg

Evcon condenser fan not running, possible capacitor

Postby Kevets » Sun May 31, 2009 5:48 pm

We have an Evcon Model BRQC036B condenser outside the house.

I believe the problem is with (one of) the capacitor(s).

One of the mounting prongs on the capacitor seems to like to burn itself off a couple of times each summer. I clean the wire, put on a new female end and reattach and everything's fine for a few months until I come home and the furnace is running but not cooling. A quick look outside shows the condenser fan not running.

Otherwise the thing runs great.

It looks similar to http://www.mobilehomerepair.com/media/img/coleman/1499-4681.jpg but only has three tabs on each disc.

Pictures can be seen at http://www.kevets.com/evcon

I'd like to order a new condenser but I'm not sure exactly which one.

Any ideas?

Thanks!
Kevets
 
Posts: 8
Joined: Sun May 31, 2009 5:30 pm

RE: Evcon condenser fan not running, possible capacitor

Postby Robert » Tue Jun 02, 2009 1:59 am

Hi,


Run Capacitor # 1499-4721 is the correct OEM run cap for your unit.


IF you want to keep a round one, then 1499-4741 will work fine also.



Both can be seen and ordered through PayPal from this page :

http://www.mobilehomerepair.com/ColemanAC.html


The number of terminal spades does not matter.




Thanks,
Robert
Some people are Humbly Grateful, while some are Grumbly Hateful.................... Which one are you ?
User avatar
Robert
Moderator
 
Posts: 6413
Joined: Wed Feb 28, 2007 12:07 am
Location: Tennessee

RE: Evcon condenser fan not running, possible capacitor

Postby Kevets » Tue Jun 02, 2009 6:13 am

Just so I understand, it was the round one I'm having trouble with. Does it not need both?

Thanks for the info, I'll be ordering soon.
Kevets
 
Posts: 8
Joined: Sun May 31, 2009 5:30 pm

RE: Evcon condenser fan not running, possible capacitor

Postby Robert » Tue Jun 02, 2009 3:49 pm

Hi,


The bigger one is for the compressor, smaller one is for the fan motor.

IF the compressor run cap was only one that was bad, then it is all you need.

With that said, if I was replacing one, I would replace both at same time.


The two p/n's I gave you, the oval one is the OEM for your unit.

That is for compressor. IF you want it to be round, then the other p/n I gave is fine also.


Run Capacitor # 1499-4421 is for the fan motor.


So, if replacing both, select one of the first two for compressor and this one for fan motor.



OR............. Dual Run Capacitor # 1498-5401 is for BOTH the compressor and the fan motor.


All can be seen and ordered through PayPal from this page :

http://www.mobilehomerepair.com/ColemanAC.html


Be sure to run screwdriver shaft (while holding insulated handle) across the terminals and discharge the capacitors before removing or use a resistor to bleed them off.



Thanks,
Robert
Some people are Humbly Grateful, while some are Grumbly Hateful.................... Which one are you ?
User avatar
Robert
Moderator
 
Posts: 6413
Joined: Wed Feb 28, 2007 12:07 am
Location: Tennessee


Return to Coleman Service & Repair

Who is online

Users browsing this forum: No registered users and 1 guest